ubuntu


Avatar utente
ale
Mac
Messaggi: 6756
Iscritto il: 27 apr 2001, 20:31
Località: Romanengo
Contatta:

ubuntu

Messaggioda ale » 15 giu 2008, 19:12

ho aggiornato l'os del mio server!
sono passato da suse 9.1 installato quasi quattro anni fa col berto a ubuntu 8.04
funziona tutto benissimo, amuled, samba, vnc su virtual framebuffer.
l'unico problema è ssh.
ti ricordi nikez? l'avevo configurato su consiglio tuo in modo da accettare tutti gli utenti dalla mia lan e solo un utente da internet.
ora non va più, ho usato le stesse due righe di configurazione, però adesso sia da dentro che da fuori accetta solo l'utente abilitato da internet.
ecco il mio sshd_config:

Codice: Seleziona tutto

# Package generated configuration file # See the sshd(8) manpage for details # What ports, IPs and protocols we listen for Port 22 # Use these options to restrict which interfaces/protocols sshd will bind to #ListenAddress :: #ListenAddress 0.0.0.0 Protocol 2 # HostKeys for protocol version 2 HostKey /etc/ssh/ssh_host_rsa_key HostKey /etc/ssh/ssh_host_dsa_key #Privilege Separation is turned on for security UsePrivilegeSeparation yes # Lifetime and size of ephemeral version 1 server key KeyRegenerationInterval 3600 ServerKeyBits 768 # Logging SyslogFacility AUTH LogLevel INFO # Authentication: LoginGraceTime 120 PermitRootLogin yes StrictModes yes RSAAuthentication yes PubkeyAuthentication yes #AuthorizedKeysFile %h/.ssh/authorized_keys # Don't read the user's ~/.rhosts and ~/.shosts files IgnoreRhosts yes # For this to work you will also need host keys in /etc/ssh_known_hosts RhostsRSAAuthentication no # similar for protocol version 2 HostbasedAuthentication no # Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication #IgnoreUserKnownHosts yes # To enable empty passwords, change to yes (NOT RECOMMENDED) PermitEmptyPasswords no # Change to yes to enable challenge-response passwords (beware issues with # some PAM modules and threads) ChallengeResponseAuthentication no # Change to no to disable tunnelled clear text passwords #PasswordAuthentication yes # Kerberos options #KerberosAuthentication no #KerberosGetAFSToken no #KerberosOrLocalPasswd yes #KerberosTicketCleanup yes # GSSAPI options #GSSAPIAuthentication no #GSSAPICleanupCredentials yes X11Forwarding yes X11DisplayOffset 10 PrintMotd no PrintLastLog yes TCPKeepAlive yes #UseLogin no #MaxStartups 10:30:60 #Banner /etc/issue.net # Allow client to pass locale environment variables AcceptEnv LANG LC_* Subsystem sftp /usr/lib/openssh/sftp-server UsePAM yes AllowUsers *@192.168.0.* AllowUsers utenteremoto@*
cosa potrebbe essere?
le due righe in fondo non dovrebbero fare il trucco?
E pluribus unum

Avatar utente
ale
Mac
Messaggi: 6756
Iscritto il: 27 apr 2001, 20:31
Località: Romanengo
Contatta:

Messaggioda ale » 15 giu 2008, 19:18

che mi veda l'indirizzo ipv6??

ecco il risultato del comando w:

Codice: Seleziona tutto

utente pts/1 fe80::21e:52ff:f 19:08 0.00s 0.54s 0.00s w
come lo convinco a leggere il mio indirizzo ivp4? :)
E pluribus unum

Avatar utente
ale
Mac
Messaggi: 6756
Iscritto il: 27 apr 2001, 20:31
Località: Romanengo
Contatta:

Messaggioda ale » 15 giu 2008, 19:37

ok, tutto apposto.
era proprio l'ipv6, qui spiegano come abilitare ssh solo sull'ipv4:
http://ubuntu-tutorials.com/2008/01/12/ ... s-on-ipv6/
E pluribus unum

Avatar utente
nikez
Nudo
Messaggi: 3498
Iscritto il: 21 apr 2002, 14:11
Località: Vaiano
Contatta:

Messaggioda nikez » 23 giu 2008, 12:58

mitttico
/* NO COMMENT */


Torna a “Linux”

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite